(0)
0 Items £0.00

Blood in urine..not infection

19 posts / 0 new
Last post
Kelcey03
Blood in urine..not infection

Hi everyone,

So worried and confused.Been having trouble with pressure in bladder area and was needing to wee a bit more. Went to doctors to get it checked out incase of infection (although I knew this wasn’t gonna be the case as my wee always smells vile with them) urine sample showed trace of blood no infection. Pressure and frequency eased off but fast forward one month later and same again. I rang my CNS to see what she thought and said she would have a word with oncologist. They have said needs investigation. So my question is has anybody had this happen? Or any idea. I’m 5 1/2 years post treatment and had stage 1b1, treated with radical hysterectomy no radiation. Obviously I have read about plenty of ppl having issues who have undergone radiation etc but as that’s not the case with me...so worried and would appreciate any advice or anybody else that’s had the same issue. 

Thank you

kelly xx

 

Flower Power

Just a thought , have you any back pain ?    Could it be a kidney stone,   this can cause blood in your urine if the stone moves.    It can come and go depending on what the stone is doing and urine tests will show blood present but no infection.   I know your mind runs riot and you always fear the worst.   Hopefully it will be something that is very easliy treated.     Good Luck XX

Flower Power

Kelcey03

Hi flower power,

thanks for replying. I’ve not really had anything like pain, maybe a twinge here n there but nothing that’s made me stop n think if you get me. I’ve heard it’s terrobke pain with kidney stones but never had them myself. Xx

Flower Power

I get them all the time they can be horrible. The pain is terrible when they are on the move and you would be fully aware that you had one. They say the pain is on parr with child birth !!!     However,  sometimes they can be there and not moving and you are unaware of them but you get the blood in urine and weird sensations within your urinary tract.   Really hope its some thing easliy rectified let me know how you get on XX

Flower Power

Kelcey03

Just an update. I’ve had my results for mri and all came back clear so next step is I have to see a urologist for a cystoscope. Thank you so much for your kindness Flower Power and for stopping and taking the time to reply. I hope you are doing great.

Kelly xx

nm_353
nm_353's picture

I had this I was diagnosed with radiation cystitis of the bladder. This can be common if you had to have radiation. My righted itself after a couple of weeks. 

June 2016- pap, not up to date, results abnormal

Julyy 5th-  After followups diagnosed with Adenocarcinoma

July 12th 2016- Met with oncologist, clinically staged at 1b2, staging confirmed with MRI and PET. Tumor is endocervical and approx 7 cm.

August 2016- Started chemorads. Post followup after treatment, NED

Sept 2018- Still NED

Kelcey03

Thanks for replying,

yeah I didn’t have anything other than radical hysterectomy. Xx

jasmine01

Hi Kelsey,

Do you ever have any spotting?

Is it blood you can see, or blood they see under microscope?

Just wondering as at the start of the year I had to keep doing urine samples as I have had issues with cystitis. I usually have the urge to go and pain, antibiotics always work straight away.

Sometimes I had no symptons and they just said they can see blood and treated me with antibiotics until my urine samples started to come back clear? Not sure if there defiently was an infection as sometimes they just did the dip test.

I do suffer from spotting so not sure if it could have been that. It wasn’t always blood I could see.

I have only had lletz so far, I get my results in a couple of weeks.

Please let me know how you get on x

 

Kelcey03

Hi Jasmine,

no I haven’t had spotting if you mean from the vagina. Just literally started needing the toilet more which prompted  me to go to the doctors incase of infection. They dip tested which showed traces of blood (nothing visible) They then sent off a sample to the lab to see if this was caused by an infection but it came back as clear. Things settled for a month then same again. So I went back to GP and it was again trace blood no infection. Took antibiotics as they give you them anyway.

when I was initially diagnosed my symptoms when I look back, were post coital bleeding and brown discharge. However I have just had a friend who has had all these symptoms and her results came back with changes but not cancer. 

I hope everything comes back good for you and I know it’s not uncommon for a woman’s wee to contain trace of blood due to thing like period contaminating it etc. This just isn’t the case for me as I’ve had everything removed.

always here for a chat and advise 

Kelly xx

Flower Power

Hello Kelly,    Great news your MRI results come back with no nasties showing.     Here is hoping the cytoscope will show the problem.    However, what nm353 is saying about radiation cystitis is very common after your treatment.    It does usually clear up and settle down with time XXX      Good Luck XX

Flower Power

Claire007

Hi, I’m interested to know how you got on. I’m about three months post radical hysterectomy and have the same issue. Feeling like I need to pee all the time, feeling of pressure... They’ve found microscopic blood and I’ve have the bladder check no issues found. I have an ultrasound on my kidneys this week but I’m a bit worried and baffled! 

X

Claire

Kelcey03

Hi Claire

i had mri which was all clear so now just waiting on gp deciding what to do next! As he doesn’t wanna do a cystoscope unless necessary, it can cause infection. He did say possibly a low threshold infection that was too low to usually cause anybody problems but in some people it can do. I’m seeing him again in a few weeks, and he will probably check my wee again to see if clear.

in your case the blood  could be related to the op as it’s still early days for you. It’s good that they are checking tho. Let me know how you get on. Xx

twhite123

 

Hi Kelly 

Sorry you had to write here but glad you did. I’m suffering something very similar. Had a radical hysterectomy in January for 1b1 with no further treatment.  Rushed to a&e in March with sepsis. Since then I’ve been on and off antibiotics for what seems to be uti, bladder or some kind of infection.  My urine samples aren’t now showing infection but increase in white blood cells.  I’ve had a ct scan and ultrasound and I’m emptying my bladder. So now I have a urologist appt on Tuesday.  I do feel I have a bit of a prolapse but non the wiser.  It’s a mystery.  I would be interested to see where your gp goes now.  It’s all very strange. I’ve been on antibiotics since March and it’s the only thing that keeps it at bay.  

 

Tess x

 

T WHITE

twhite123

Hi Kelly. Not heard from you but I’m in exactly the same boat. I’m not under a urologist who made me come off antibiotics to check infection. 6 days later I was in A&e with major pain and struggling to we.  My urologist has booked me in for the camera too just waiting for the appt.  my sample at a&e showed slight blood on urine but blood tests showed no infection.  Back on antibiotics but still struggling to wee and fully empty my bladder and so sore inside.  Would be great to hear back from you.  X

T WHITE

Kelcey03

Hi twhite, sorry I’ve not been in touch sooner, I’ve not been on here in a while. I’ve since been back to my doctors and will continue to do so for a while to keep checking urine. It’s been clear the last few times so he has held off with the urologist for now! He did suggest however that could possibly be a water infection that was too low to pick up with their thresholds. I was the same as you though with getting sepsis after my radical hysterectomy. And I certainly can’t empty my bladder properly ever since. It picked it up as being distended on my mri even though I had just been to toilet!

i hope you are getting some answers now as mine still seems a mystery some days wanna pee a lot n others can go 7 hours plus without goin. So is it a possibility of low grade infection? Also I’ve heard of a thing called interstitial cystitis which can cause bleeding and mimic basically a uti but nothing ever comes back in the tests.

kelly xx

 

twhite123

Hi Kelly.  

 

Many thanks for contacting me.  It’s a complete mystery here it feels like when I’m off antibiotics my tube is closing up and just can’t wee.  It’s awful.  I’m glad you’re improving.  Hopefully it will settle down.  I’m just waiting for my appointment for the camera hoping that will give me some answers.  It does feel sore inside a lot so something isn’t right. 

 

Let me know how you get on.  Hoping it will clear up for you.  

 

Tess x

T WHITE

Kelcey03

Did you say if they have given you an MRI? Just to rule out blockages etc. Also have you long to wait for your camera? At the end of the day you know your own body and if it doesn’t feel right it needs sorting. I kept having like a sore and weird pressure feeling for months even though apparently no infection! 

twhite123

I’ve had a CT scan and ultrasound. Nothing strange has showed. I’m still waiting for an appt for the camera.  Definitely something not right.  Just need a solution. 6 months now I’ve been on antibiotics with no Infection showing now. I will certainly keep you updated to when I’ve had the camera.    X

T WHITE

Kelcey03

Yes please do I’ll be thinking of you. Very strange but nobody knows your body like you. That waiting though is the worst. I hope you get answers and sorted sooner rather than later. 

Kelly xx

More Information

Moving forward from a cancer diagnosis